Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Linux installation: Second Ethernet interface ...

Hi again.  First, I thought y'all might like to hear  a  great  quote
from the editorial page of today's Boston Globe. In talking about the
Microsoft vs the Justice Dept, he says "The notion that an  operating
system is distinguishable from an Internet browser and other software
is simply idiotic."

Looks like we're all idiots, huh?

Anyway, on to the topic at hand.  After deciding to get serious about
upgrading  this  linux  system (which idiotically seems to still have
several browsers that aren't part of the kernel), I've  succeeded  in
installing  Redhat  5.1,  and after the Mediaone folks dropped by and
installed their modem into W95, I rebooted linux, and  it  talked  to
the cable instantly, with no problems.  Pretty impressive.

Now  it's onward to making the 2nd Ethernet card work and talk to the
W95 box across the room (which also has an  Ethernet  card  that  was
just installed).

After spending a couple of days trying to get linux to create an eth1
and associate it with the 2nd card, I've decided that  I  just  don't
get it.  Maybe someone out there can make suggestions.

One  puzzle  is  that I've been using the control panel, and its cute
little Network Configurator window looks like  it's  doing  the  job.
I've  several times created (and/or removed) the eth1 interfact, with
an IP address starting with 10..., proto=none, atboot=yes,  and  I've
pressed  the Activate button so that it says "active" in the "active"
column.  And I've pressed the Save button.  No eth1 in  sight.   Both
"ifconfig -a" and "netstat -i" show lo0 and eth0, but not eth1.

I've  also  tried several suggestions from the various HOWTOs and the
mediaone  web  page,  especially  the  bit  about  adding  things  to
/etc/lilo.conf, and none of them has worked.  During boot, it says:
   ...  modprobe:  can't locate module eth1
and sure enough, there's no eth1. Of course, I'd think that "eth1" is
the name of an interface (i.e., a data structure in the kernel),  not
a module (whatever that may mean here).  But what do I know?

In any case, the terminology seems a bit confused.  What does it mean
to "activate" an interface?  Is this a synonym for "create"?  If not,
when does should interface get created?  And what sort of "module" is
the boot code looking for and not finding? It should already have the
code for an Ethernet interface, because it has eth0;  eth1  shouldn't
need much more than a new entry in a table.

Anyhow, I thought I'd toss this out to some of the folks who've  done
it,  and  see  if there's something that should be obvious, but which
I'm just missing.

Now let's see what the email "system" does with this.  With  mediaone
hooked  up,  it'll  probably  go  out ok, but if your mailer wants to
respond to the From:  address rather than the Reply-to:  address,  it
might not work.  Here goes ...

When puns are outlawed, only outlaws will be punished.

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /