Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

upgrading 486s BIOS

The hard drive settings (num of cylinders, num of heads, num of sectors)
that the BIOS figures out are not necessarily used by linux.  You should be
able to stay with a working motherboard BIOS and just pass boot line append
statements.  I did this on an older motherboard that would not recognize a
17GB hd and it still doesn't recognize all of it.  But I tell linux to
ignore what the BIOS tells it by passing this in a LILO prompt append:


suddenly I now have use of the whole drive :)

so when you know the cylinders, heads, and sectors (which of course is with
the hard drive docs), then you can pass linux options through LILO or at the
LILO prompt.

the relevant parts of my lilo.conf look like this:

	append="hdb=33483,16,63 ether=11,0x7c00,eth1 ether=9,0x7f80,eth0"

you should be able to pass the options for hda as well (I think) as long as
/boot is readable before linux takes over and tells the BIOS to mind it's
own business.

hopefully that helps somewhat or at least gives you some new options to try.


ps - now that I read your post again...perhaps enabling the "boot off-board
controllers first" (it's something like that) in the kernel configuration
may tell linux to try to go through the non motherboard BIOS to get the hard
drive info - this might be a wild goose chase though (or a tame one :)

> -----Original Message-----
> From: Leslie Owen Everett [mailto:leverett at]
> Sent: Monday, November 22, 1999 10:01 PM
> To: discuss at Blu.Org
> Cc: discuss-digest at Blu.Org
> Subject: Re: upgrading 486s BIOS
> Perhaps someone reading the list has resolved this already,
> Recently I inherited ten working DELL 486/MEs with: 66 MHz, 
> 325MB hard drives, and 32
> MB RAM. Eventually I plan to use them to build a Beowulf 
> system. I installed a 6.0 GB
> hard drive on one of them with SuSE Linux 6.0, it works fine 
> and is now my primary
> Linux box.
> I partially installed Red Hat Linux  6.0 on another 486. The 
> installation was
> incomplete needing 770 MB or so.  I decided to upgrade with a 
> 8.4 GB drive, and had to
> upgrade the Phoenix Ltd. BIOS. The BIOS can't see the 8.4 GB 
> hard drive. I bought a
> "DTC Ultima EIDE port and BIOS upgrade card" (for older 
> computers if BIOS does not
> support HDD greater than 500 MB) and plugged it into an ATI 
> slot. I couldn't partition
> "/dev/had", only starting at "/dev/hdc". The new BIOS more or 
> less recognizes the
> large ATA drive and reports this, but the machine defaults to 
> the Phoenix Ltd. BIOS.
> It advises checking the jumpers, I tried, switching the drive 
> from Master (default) to
> Slave, with the same results, can't access it.
> I installed Red Hat 6.0 on this machine and it worked fine, 
> except I was unable to
> access "/dev/had", or "LILO" , so I had to boot Linux from a 
> floppy. I read in "Linux
> secrets" Linux cannot be installed via a secondary BIOS. My 
> question is: Has anyone
> successfully installed Linux after upgrading the BIOS on a 
> 486? Short of going ahead
> and replacing the motherboard, this might be an exercise in 
> futility, but I'm not
> convinced yet.
> Thanks in advance for any information,
> - Leslie Everett
> -
> Subcription/unsubscription/info requests: send e-mail with
> "subscribe", "unsubscribe", or "info" on the first line of the
> message body to discuss-request at (Subject line is ignored).
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /