Boston Linux & UNIX was originally founded in 1994 as part of The Boston Computer Society. We meet on the third Wednesday of each month at the Massachusetts Institute of Technology, in Building E51.

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss] I, uh, deleted the wrong kernel....

On my desktop machine (Kubuntu 16.04LTS I think), I set up /boot too
small, because at one point my distro automatically removed old kernels,
so there wasn't need for much space.  But that doesn't happen anymore,
so sometimes it fills up.  Well it turned out that when I went to delete
some of the older kernels, it turns out I was actually running one of
them, and now Grub is very unhappy.  This is dual boot with Windows,
which still works. 

I'm sending this from my laptop.  It's now like 2AM so I need to get to
bed.  I have tried a bunch of things, but clearly I didn't exhaust
Google yet.  I'm posting this in case someone who has experience in this
can just head me towards The One True Way to fix this.  I will continue
trying tomorrow though.

Grub is looking for vmlinux-4.4.0-28-generic, and I have
vmlinux-4.4.0-34-generic and vmlinux-4.4.0-36-generic still.

- I tried booting from USB, mounting root and boot, and simply
symlinking the 36 kernel to 28. I ended up at some initrd prompt.

- I tried both mechanisms at
(tl;dr  mount some of the root partition then  chroot to |||it and run "|
|apt-get install linux-image-generic").  It reported endless
dependencies that couldn't be met.  I have a feeling I may need to try
this again after finding the magic command to remove anything from the
"scheduled to be installed" list.

|- I tried the above chroot thing, then to |grub-set-default to a
kernel I *do* have, but it still looked for  Maybe I did the
chroot wrong? Maybe I forgot a step?

I suppose the nuclear option would be to reinstall over the current
install without reformatting and maybe kinda it may work.  I welcome
other ideas to try.  Like I said I will continue to work on this
though.  Far from waving the white flag but close to my bed.


BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /