Boston Linux & UNIX was originally founded in 1994 as part of The Boston Computer Society. We meet on the third Wednesday of each month at the Massachusetts Institute of Technology, in Building E51.

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss] Ubuntu 17.10: As messed up as it appears in first impression?

For closure... I found an i3 laptop to try the install on. Not only did 
I get it installed flawlessly, and dual-booting with Windows 10, but 
everything seems to work fine, other than running applications as root, 
which is a known problem, and relatively easily fixed by telling it root 
can open windows.

I think with gnome-tweaks, I could adapt to its look and feel. I'll have 
to play with it more and install more software though. As Bill would 
agree, I would not fool around with this on a mission critical machine.

So far I'm happy-ish, but... Looking at the bug reports, they seem 
entirely unconcerned about everyone complaining that root-run 
applications don't just run. Like if you download a .deb, the browser 
will try to launch the installer and fail. That's pretty unacceptable.

On 10/21/2017 01:28 AM, David Kramer wrote:
> Disclaimer: I'm just booting it off a thumbdrive and played with it 
> for like 30 minutes.  Definitely not exhaustive, and running from 
> thumb drive some things aren't gonna work.  But I've been a long-time 
> Kubuntu user trying to see if I could adapt to the new 
> Gnome/Wayland-based version.
> First thing I noticed is that Software Center is... lacking. I 
> understand it's for less sophisticated users.  so I try to install 
> synaptic.  "sudo dpkg-query -l synaptic" shows it but with no version 
> number, no arch and uninstalled. "sudo apt-get install synaptic" says 
> the package has no installation candidate.  Same goes for 
> gnome-tweak-tool, which seems similarly essential. Separately, I know 
> if I do manage to install synaptic I will run into easily-solved 
> problems running it as root, according to the Internet.  Yes the 
> machine is connected to the Internet.
> I tried installing some other packages, and ran into the error 
> "snap-confine has elevated permissions and is not confined but should 
> be..." when I run them from the command line. They don't do anything 
> when I click on the icon in the application list. Google isn't helping 
> me with that one either. The applications don't launch.
> Other opinions on it welcome, but specifically:
> 1) Is Ubuntu 17.10 ready for casual use?
> 2) Are others seeing the problems I'm seeing above? It's effectively 
> useless to me as is, and mysterious that there aren't a lot of hits on 
> these messages.
> 3) Is it likely these problems are being caused by running from a 
> thumb drive?  I have a feeling any spare machines I have to try it on 
> are 32 bit, and I would rather not blow away my main laptop install 
> only to find out I don't like the interface.
> Thanks.
> _______________________________________________
> Discuss mailing list
> Discuss at

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /