Segmentation fault (solved ... sort of)

Brad Noyes maitre at
Sun Feb 6 22:57:55 EST 2000

Hi all,

Thank you everyone for responding. The problem - Well i was almost sure that my
problem was a bad pointer of some sort. I'm not as fluent with pointers as I'd
like to be. And sure enough that was why i was seg faulting. But i couldn't
tell where the problem was because i could look at a core dump which usually
is created with a seg fault. 

Why didn't i get a core dump? Well i haven't been using Mandrake for very long,
only about a few weeks. I'm still getting used to it. I tried ulimit, and it
was set to unlimited. So that wasn't the problem. I then tried to run the
program as super user (by accident, i didn't realize i was in su). And then i
got a core dump, which made me happy. After a few tests I concluded that with
Mandrake, only root, or super user can create core dumps.

I've head of security exploits using a core dump. So i guess thats why
Mandrake allows only root to create core dumps. 

Now i have to info to fix the problem I just have to figure out how to fix the
problem ... 

Thanks again,

Subcription/unsubscription/info requests: send e-mail with
"subscribe", "unsubscribe", or "info" on the first line of the
message body to discuss-request at (Subject line is ignored).

More information about the Discuss mailing list