Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

slip/ppp/term brief report

I wanted to try running internet over the phone,
so I tried the three following methods

   slip 0.7.5 using cslip (and dip)
   term 1.17 with kermit startup
For testing the speed, I used an ftp transfer (term needs
a special version) on gzip-compressed files over
100Kbytes in size; the modem was set at 14.4 baud
RTS/CTS; I did the tests between 2AM and 4AM, when
the network traffic should have been relatively light.

   ppp     1.1 K/sec
   cslip   1.1 K/sec
   term    1.0 K/sec

Some of you may be wondering if my modem was kick-down
to 9600, but as far as I can tell, this was not
the case.  The lower data rates seem to arise from
pauses in the transfer (based on my observation of
the modem idiot-lights).

In all cases, X-over-the-wire was slow (even at 14.4K)
but doable.

misc. comments:

ppp seemed to be the jerkiest of the three.  It does
provided addition error checking, so the pauses
may be due to some addition handshaking
(anybody - how do I check?).  If you net packets
have _no_ error detection, you may want to use
this protocol.
To break the connection, I had to turn off the modem.
Killing pppd did not suffice.

the smoothest response, but you may still suffer
network delays.  The transfer rate was little different
from ppp for large files, though.
To break the connection, I had to turn off the modem.
"dip -k" did not suffice. 

requires some extra set up.  I used kermit to make
the initial connection (anybody have a script to
automate the whole process).  I put kermit
to sleep after "exec term -l $HOME/tlog" on the remote.
To run X over the wire,
you need to run txconn (remember to set DISPLAY and xhost)
or some equivalent procedure.  tredir can be used to
redirect port and several clients (like ftp and mosaic)
have been modified to run over term; remember that
your are using the remote's nameserver (do not rely
on what is in your local /etc/hosts file).
The most important thing seems to be keeping
the number of links between your local and the remote
to a minimum; ideally, your remote should be hooked
directly to a modem; in any event, do not (like I did)
try telnet-ing from one remote to another and then
running term on the second remote.
I also have problems with trsh (if I run a shell,
the prompt gets eaten -- why?).
tshutdown did break the term connection,
but I needed to bring kermit to the foreground
to break cleanly the connection.

Finally, the various set-up files with certain
bits of fictious information (all are modifications
of samples provided with the packages).

for ppp, a shell script:
  pppd connect \
   'chat -v "" ATTDT123 CONNECT "" ogin: nemo word: a1234' \
   /dev/cua1 38400 -detach debug crtscts modem defaultroute

the dip script:
    # First of all, set up our name for this connection.
    # I am called ""  (==
    get $local <>
    # Next, set up the other side's name and address.
    # My dialin machine is called '' (==
    get $remote <>
    # Set the desired serial port and speed.
    port /dev/modem
    speed 38400
    # Reset the modem and terminal line.
    # This seems to cause trouble for some people!
    # reset   <it did, for me>
    # Prepare for dialing.
    send ATQ0V1S37=11N0E1M0X4\r  #<check your modem manual>
    wait OK 2
    if $errlvl != 0 goto modem_trouble
    dial <remote's phone number>
    if $errlvl != 0 goto modem_trouble
    wait CONNECT 60
    if $errlvl != 0 goto modem_trouble
    # We are connected.  Login to the system.
    sleep 2
    wait ogin: 20
    if $errlvl != 0 goto login_error
    send <your account name>\n
    wait ord: 20
    if $errlvl != 0 goto password_error
    send <your password>\n
    # Set up the SLIP operating parameters.
    get $mtu 1024
    # Say hello and fire up!
    print CONNECTED $locip ---> $rmtip
    mode CSLIP
    goto exit
    print TIME-OUT waiting for SLIPlogin to fire up...
    goto error
    print Trouble waiting for the Login: prompt...
    goto error
    print Trouble waiting for the Password: prompt...
    goto error
    print Trouble ocurred with the modem...
    print CONNECT FAILED to $remote

and the $HOME/.term/termrc file
  compress off
  escape 17
  escape 19
  escape 28
  escape 29
  escape 145
  escape 147
  escape 156
  escape 157
  baudrate 19200
  shift 224
  window 6
  timeout 200
  noise on
  ignore 17
  ignore 19
  ignore 28
  ignore 29
  ignore 145
  ignore 147
  ignore 156
  ignore 157
  breakout 24

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /