Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


  For a long time I was running linux-1.0.9 without problems. Yesterday,
I decided to upgrade my entire system by doing a full install from scratch.
I originally built my system using a slackware distribution. Since that had 
worked so well, I decided to rebuild using slackware 2.1. This is when my
problems began. My system would boot fine when using the boot and root disks
but it would often die during the install. I then decided to boot my machine
using the boot and root disks and leave it to see if it would hang. It would,
and the time always seems to vary. 

  At this point, I tried using the old slackware boot and root disks (1.0.9 
kernel) and then use the latest installation disks. The install would work but
the system would hang after I rebooted using the new kernel. Ok, so I looks
like the kernel doesn't work on my machine. So I then used another linux box
(which was built using slackware 2.1) to compile an almost bare 1.0.9 kernel
and then made a boot disk out of it. I then built my machine using the old 
boot and root disks and the new A series from slackware (base system). I then
tried to boot my system using the 1.0.9 bootdisk I had made. The system gets
goes so far and then bails with:

Partition check:
  hda: hda1 (my dos drive)
  hdb: hdb1 hdb2 hdb3 hdb4 (my linux drive)

MINIX-fs:unable to read superblock
EXT2-fs: unable to read superblock
XIA-fs: read super_block failed (inode.c 74)
MSDOS bread failed
Kernel panic: VFS: unable to mount root

 This puzzles me. I formatted the filesystems ext2 before I had started the 
install. Why can't the 1.0.9 kernel handle the filesystems?

 Does anyone have any clues on what could be done with this whole problem?


BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /