Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

strange unmounting problem.

  I recently did the redhat kernel upgrade to 2.4.9-31 and found that an old 
smartmedia reader I had now works :)  (Lexar USB SmartMedia Reader) and shows 
up as vfat formatted scsi drive.  
Everthing went fine until I tried to unmount it.  It says the device is busy 
and when I run fuser -v on it the device it says that mount is tieing the 
device up.

/etc/fstab entry:
/dev/sda1	/mnt/smedia	auto	noauto, user, rw	0 0

data from of 'fuser -v /mnt/smedia'
/mnt/smedia	root	kernel	mount	/mnt/smedia

Now this doesn't make any sence to me, because the device sucessfully mounted 
and i was able to copy my pictures off of it with no problem.  So why is 
mount still running on it?  Oh just to confuse matters, if I log out of X I 
can unmount it.  Any ideas?   (oh yea, this is all being done from my user 
account, not root)


BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /