Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Seg Fault

Hey y'all:

I'm running Win 98 dualed with Red Hat 6.2.  The Windows OS died a long time
ago (no complaints) and I've just been using the GNU/Linux side.  I have a
single hard drive partitioned a few ways:
hda1 is known as /mnt/dosc in the linux side
hda7 is known as /mnt/dosd in the linux side
As the names indicate, they are FAT32 drives that were visible by both
partitions.  /mnt/dosd has the bulk of my data -- photos with captions, code,
my masters thesis (I have backups, but the LaTeX was groovy), mp3s (less
important), and assorted other data.

At any rate, I went to access it the other day while in gnome and it shut the
application down.  Eventually, I exited gnome and just tried to more a textfile
in /mnt/dosd and got this:

Unable to handle kernel NULL pointer dereference at virtual address 00000000
current->tss.cr3 = 0e216000, %cr3 = 0e216000
*pde = 00000000
Oops: 0000
CPU:	0
EIP:	0010:[<00000000>]
EFLAGS:	00010246
eax: 00000000	ebx: ce0f8110	ecx: ced31a00	edx: ce0f8228
esi: c024c0b8	edi: ce0f9119	ebp: c024c0b8	esp: ce1d9f28
ds: 0018   es: 0018   ss: 0018
Process ls (pid: 927, process nr: 33, stackpage=ce1d9000)
Stack: ce0f8110 00000000 c024c0b8 0000014d ced31a00 c01318dc ced31a00 0000014d
       c024c0b8 00000014 ce0b9027 d486182b ce1d9f78 d4861444 ced31a00 0000014d
       00000014 ce0b901c 00000003 ce0b9026 ce1d9fbc d486137e ced31a00 ce0b901c
Call Trace: [<c01318dc>] [<c010a0d4>]
Code: <1>Unable to handle kernel NULL pointer dereference at virtual address
current->tss.cr3 = 0e216000, %cr3 = 0e216000
*pde = 00000000
Oops: 0000

...lotsa the same stuff.. flags, registers, stack ...

Code: 8a 04 0b 89 44 24 38 50 68 b0 91 1d c0 e8 ee 98 00 00 83 c4
Segmentation fault

I've tried using dosfstools to help, but couldn't get anywhere.  I booted on
the windows side and scandisk gets to about 83%, says "crosschecking names" and
then reboots.  I booted to dos and can see the directories using dir but when I
get deep enough in any subdirectory (just how deep "enough" is varies) I get an
Abort Retry Fail.

I searched google for the beginning of the error message I posted, and there
are a few other postings of the same error messages to discussion panels like
this one -- never with an answer that I could find.

I just want to be able to access the data.  I'll then back it up (I'm really
broke, so I haven't been able to afford an external CD-RW for my laptop... but
I'll get one now if it means I collect quarters at Ruggles) and once its backed
up, I can wipe the entire 30 gig drive clean and reinstall Red Hat 7.3 or
whatever with no Windows/FAT32 partitions whatsoever.

So... any ideas?  tjvitolo<at> if you please.  Thanks in advance!

Do You Yahoo!?
Yahoo! - Official partner of 2002 FIFA World Cup

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /