Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

the linux networking utilities hate me

Until last night, I had an AirPort base station assigned to IP address  My Linux (Debian stable) laptop has a wireless Ethernet 
card as device eth1, and the configuration for the card, in 
/etc/network/interfaces, describes it as "pointopoint ... 
gateway ..." and everything worked just fine.  If I typed 
"/sbin/ifconfig eth1", the output would report the point-to-point link, 
and if I typed "route -n", the output would begin something like this:

Network      Gateway      ... Device *            ... eth1 ... eth1

Then I swapped out the AirPort, and replaced it with a Linksys base 
station whose default IP address is  No problem, I 
thought.  I'll just replace "11" with "245" in /etc/network/interfaces, 
reboot, and everything should work just as before.  But it doesn't.  I 
*can* access the Web interface of the base station itself by typing 
""; into my browser, but I can't access anything else.

Even when I explicitly type "/sbin/ifconfig eth1 ... pointopoint", and then type "/sbin/ifconfig eth1", the interfaces is 
no longer flagged as point-to-point.  Now, when I type "route -n", the 
output begins

Network       Gateway      ... Device      ... eth1

I've tried "route add -host eth1" and "route add -host gw" (.13 is the address of my laptop's 
wireless card), with the same results.

What am I doing wrong?  Is there another configuration file that I 
forgot about?  Is a misconfiguration on the wireless base station 
causing the kernel routing tables to become confused?  Am I just cursed?

// seth gordon // sethg at // //

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /