Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

usb drive corrupt


I've got a 1 gig Lexar USB thumb drive that has been working well for 
about a year.  I've been using it for backups and to transfer files from 
Linux to M$.  The drive appears as a DOS partition.  Recently, when I 
insert the drive into a Windows box (2000, 2003, XP), M$ says that the 
drive is corrupt!  However, I can still mount it using a couple of Linux 
boxes and a MAC.  There is no corruption that fsck can detect.  I have 
tried several Windows machines, all with the same result.

Any ideas, explanations, wild-ass guesses???

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /