Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

pam configuration

thanks for all the suggestions.

cracking the passwords wasn't an option, this is for a financial company and
they don't have a sense of humor about that sort of thing...
after mangling /etc/pam.d/vsftpd and running authconfig.  it looks like i
should have verified the accounts on the source machine worked correctly!
half of the accounts and passwords i was given to test with were bad!!!
after figuring out which ones worked on the source machine, copying the
encrypted string to the linux server, ftp authentication worked like a

thanks again for the suggestions.

On 11/15/06, John Boland <jj.boland at> wrote:
> folks,
> i've got a strange config request dumped on me.  external ftp server is
> being moved from sun os (yeah, it's that old!) to linux.
> there are almost 300 ftp accounts that need to be moved.  the linux box is
> already setup with some accounts using md5 passwords and they work well.  my
> problem is that the customers using the ftp service have passwords (yes, i
> know that's a BAD thing, but they're customers!) embedded in scripts that
> handle the file transfers and it will be practically impossible to get them
> to change the password (or tell us what it is so that we can change it).
> so, what i've thought is to simply copy over the encrypted passwd string
> from the sunos shadow file to the linux shadow file.
> i've tried this using a couple of test accounts on the sunos box, no joy
> in mudville!
> so, for two of the test accounts, i changed their passwords to md5. but i
> couldn't authenticate on the linux box.  this was due to an invalid shell
> being setup for the account, /bin/false. i removed the "auth"
> line from /etc/pam.d/vsftpd and the accounts that i changed to md5 now work!
> so, i'm trying to figure out how to allow md5 and unix-style passwords on
> the same system. i've added "account" to no avail.
> are md5 passwords an all or nothing setting?
> any tips/thoughts/directions???
> tia...
> --
> If it ain't broke, you're not trying hard enough!

If it ain't broke, you're not trying hard enough!

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /