Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Csh /Tcsh Issue

Hi all,

I have an issue with csh and environment variables. In csh/tcsh I can only
use environment variables when I quote them. For example see the example

providence% setenv CLASSPATH
providence% echo $CLASSPATH
echo: No match.
providence% echo "$CLASSPATH"

While this is not much of an issue for me, it causes issues when I run other
people's scripts. I have tried using other people's .cshrc where the above
commands work as expected, but it doesn't seem to work on my machine. I am
not sure where the problem is. Any ideas on why this is happening?


BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /