Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

odd problems

I'm not sure about the scanner, but I had a similar problem with audio
a couple months ago, on a laptop with Fedora 10. When I first installed
Fedora 10 in November, audio worked fine, but one day it failed after
a set of updates.

In the end, it turned out to be related to my laptop's built-in webcam,
which has an internal microphone. Apparently it's wired up as a USB
device, and in November it was unsupported in the kernel.

A kernel update in December suddenly provided support for the webcam,
at which point it became the primary audio device.  ALSA had hard-wired
the normal sound card to be audio device 0 in /etc/modprobe.conf,, and
when it tried to initialize the device at boot time, the webcam microphone
had already grabbed the spot for audio device 0, and the sound card
initialization failed as a result.

I think I deleted the sound card from /etc/modprobe.conf, and after
rebooting and then updating the audio preferences, sound was
working again.

If the scanner is USB, then maybe its problem is also related to
other USB hardware that only became supported recently.

On Fri, Feb 13, 2009 at 12:16 PM, dan moylan <jdm-LPA1KyJyIuz1P9xLtpHBDw at> wrote:
> running ubuntu 8.10 on panasonic cf50 laptop.  mid january,
> all was well.  then sometime at the beginning of february,
> three disconnects occurred, whether related or not, or at
> the same exact time, i can't say.
>  - audio ceased to work; running gnome-volume-control
>    produced an error window saying "No volume control
>    GStreamer plugins and/or devices found."
>    the "services settigs" gui shows a white box beside
>    "audio settings managemnt (alsa utils)" and will not
>    accept a check.
>  - the scanner function on the hp4580 printer/fax/scanner
>    ceased to work -- xsane doesn't find any scanner; the
>    printer continues to work fine, and when plugged into
>    a different computer, the scanner works fine.
>  - the login gui no longer appears, so i login via a text
>    screen, and use startx -- no biggie, but what ever
>    became of inittab?
> these things seem so unrelated ... and i can think of no
> action i took that might have triggered them, but who knows?
> my first inclination is to reinstall the operating system,
> but i thought i'd first ask if anyone has any better
> suggestions.  tia.
> dan
> j. daniel moylan
> 84 harvard ave
> brookline, ma 02446-6202
> 617-232-2360 (tel)
> 810-454-1823 (fax)
> jdm-LPA1KyJyIuz1P9xLtpHBDw at
> [death to html bloat!]
> _______________________________________________
> Discuss mailing list
> Discuss-mNDKBlG2WHs at

John Abreau / Executive Director, Boston Linux & Unix
GnuPG KeyID: 0xD5C7B5D9 / Email: abreauj-Re5JQEeQqe8AvxtiuMwx3w at
GnuPG FP: 72 FB 39 4F 3C 3B D6 5B E0 C8 5A 6E F1 2C BE 99

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /