Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

VirtualBox: No USB?

Backstory: I have an ancient Thinkpad T42 running Windows XP.  I have
only two uses for Window; backing up/sycning my iPhone, and VPNing into
work.  The Thinkpad's Windows install is broken, and it BSOD's seconds
after booting.  I may or may not reinstall Windows on it.

I found an XP image I made in VirtualBox a while ago on an external USB
hard drive.  I installed VirtualBox on my main laptop (Dell D830
Centrino dual core duo).  I tried it for VPNing into work, and that
worked pretty well.  However, I can't find any way of seeing USB devices
(like my iPhone) in the VM.

I see all sorts of tutorials online that refer to there being a
button/icon that lists USB devices that I can choose to take control of,
but I don't see one.

This is what I have installed:
$ dpkg-query -l '*virtualbox*' | grep ii
ii  virtualbox-guest-additions
   guest additions iso image for VirtualBox
ii  virtualbox-ose
   x86 virtualization solution - base binaries
ii  virtualbox-ose-dkms
   3.2.8-dfsg-2ubuntu1~lucid1 x86
   virtualization solution - kernel module
ii  virtualbox-ose-qt
   x86 virtualization solution - Qt based user

$ uname -a
Linux lexa 2.6.32-27-generic #49-Ubuntu SMP Wed Dec 1 23:52:12 UTC 2010
i686 GNU/Linux

$ cat /etc/issue
Ubuntu 10.04.1 LTS

PS I'm willing to go with a different VM solution.  I just chose
VirtualBox because I already had a VirtualBox VM image and most of the
articles I found on using a Windows VM to talk to an iPhone used VirtualBox.

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /