Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss] Linux Mint Cinnamon Home Permissions

Thanks for the tips guys!  I tried to recreate the problem and ran into 
a couple of new ones, lol...

(1)  I couldn't figure out how to switch to the Gallium driver. After 
searching online to no avail, I tried switching the "Driver" line in 
xorg.conf to "gallium."  That didn't seem to work.  When I logged back 
in, the display was super low resolution and listed the driver as i915.

(2)  I figured that removing the package for the nvidia driver would 
switch me back to Gallium.  It didn't.

(3)  I reinstalled the nvidia driver.  Nowhere along the way did it 
change the permissions on my home directory.  However...

(4)  When I got back into Cinnamon, I lost settings that you wouldn't 
expect I would have lost.  For example:
a-  My language setting was lost
b-  My panel settings were back to the default
c-  My window settings (e.g. where the maximize/minimize/close buttons 
appear) were back to the default
d-  I had my GMail account configured in Pidgin for GTalk and the 
account was gone.
e-  Also, in Pidgin, I had disabled the lib-notify plug-in.  It was 
f-  When I started Firefox, it checked for plug-in compatability, which 
it only does the first time you run it after installing a new version, 
so it seems to have forgotten it had already done this
g-  In Terminal, I had changed the colors.  These went back to the defaults.
h-  When I look at my bash history, I don't see any of the apt-get 
commands I used for this experiment or the editing of the xorg.conf 
file, which leads me to believe I may be going crazy.

I'm guessing some or all of the above settings were all stored in my 
home directory.  So like I said, I couldn't recreate the original 
problem, but I managed to create some new ones.


On 12/11/2012 04:24 PM, Derek Martin wrote:
> On Tue, Dec 11, 2012 at 03:39:15PM -0500, Jerry Feldman wrote:
>> On 12/11/2012 01:53 PM, Derek Martin wrote:
>>> You could follow Bill's suggestion and pull apart the package and see
>>> what it does.  Or you could just test it...  Being very careful not to
>>> run anything else, log in to your system, change the driver back to
>>> gallium.  Log out, and check your ownership and permissions.  Then log
>>> in again, update it to nvidia again, and do your check again.
>> Possibly an easier way is to make sure everything is Kosher including
>> your home directory permissions and ownership, then after you have
>> verified, reinstall the package that you think caused the problems, then
>> double check the ownership et. al. Then you can terminate your X session
>> by logging out. You should be able to log in once again. Or if the
>> problem is the same as before, then you can assume that the package you
>> installed is the culprit.
> Possibly easier, or possibly harder.  It's almost exactly what I
> suggested, except it leaves out the step of returning the machine to
> the state it was in prior to upgrading the driver.  If the problem is
> caused by an interaction between those two, skipping that step will
> obviously not trigger it...
> _______________________________________________
> Discuss mailing list
> Discuss at

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /