Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss] memtest86+ oddities

While fixing up a Windows installation on some laptop hardware I was
attempting to use the Widows installer, which consistently crashed with
an error message that the Internet says is indicative of a memory error.

So I grabbed an Ubuntu CD I had handy, which happened to be the 12.10 CD
from the last BLU meeting, looked up how to get into memtest (you need
to hit ESC when the splash screen first appears), and kicked off a test.

Around the 130 M mark on test #7 it started spewing out thousands of
errors. I swapped the order of the two 1 GB modules. Same result. Tried
each module by itself. Ditto. Different slots. Same. And then I tried a
512 MB module I had. Same result.

It was looking like the motherboard had a fault, but I happened to try
an Ubuntu 12.04 CD I had handy. Magically that fixed it. It ran
overnight testing the original 2 modules without error.

Both CDs uses the same version of memtest86+, 4.20.

I wonder what the difference is? Corrupt CD? (Both are official, mass
produced Canonical CDs.)

(The crashing installer was apparently due to the installer not
recognizing the SATA controller, rather than a memory problem.)


Tom Metro
Venture Logic, Newton, MA, USA
"Enterprise solutions through open source."
Professional Profile:

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /