Boston Linux & UNIX was originally founded in 1994 as part of The Boston Computer Society. We meet on the third Wednesday of each month at the Massachusetts Institute of Technology, in Building E51.

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss] stumped: machine won't boot

On Sat, Jun 27, 2015 at 7:20 AM, Laura Conrad <sunny at> wrote:

> >>>>> "Bill" == Bill Bogstad <bogstad at> writes:
>     Bill> On Fri, Jun 26, 2015 at 8:39 AM, Laura Conrad <
> sunny at>
>     Bill> wrote:
>     Bill>     My desktop is a lenovo I bought last fall. It has only ubuntu
>     Bill>     installed
>     Bill>     on it. There is a 500M boot partition, which seems to have
> been
>     Bill>     clobbered. The / partition looks fine, and in fact includes a
>     Bill>     /boot
>     Bill>     directory that looks normal to me.
>     Bill>     I rebooted it a couple of days ago because of a new kernel,
> and it
>     Bill>     wouldn't boot.
>     Bill>     It says it can't find an OS. I have tried boot-repair, and it
>     Bill>     thinks
>     Bill>     it has repaired things, but I still get the message about not
>     Bill>     being able
>     Bill>     to find an os.
>     Bill> Can you give the exact error message?
> Error 1962: No operating system found.
>     Bill> "Can't find an OS" type messages could even be from the BIOS
>     Bill> which might mean that your boot block is corrupted or your
>     Bill> boot partition isn't marked bootable.
> I assume it is from the bios, because Grub never comes up.  I have been
> trying via gparted and boot-repair to fix this, but it still give me the
> message.  I'm going to try Richard's suggestion of SystemRescueCD next,
> but I don't have a lot of hope.
> I assume this is UEFI or GPT or one of the other things that makes
> installing
> linux harder than it used to be.

Could be.  Googling for that exact error message and "ubuntu" finds quite a
few references
about legacy BIOS vs. UEFI booting for a wide range of Lenovo systems.   At
least one
suggested that a BIOS upgrade might help.   You might try reading some of
the discussions
found by doing the search and see what makes sense to you.

Bill Bogstad

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /