sendmail Segmentation fault

David Kramer Dskramer at
Wed Aug 12 00:36:45 EDT 1998

When I try to run sendmail with any parameters (or none), I get a
Segmentation fault, sometimes with a core dump.

My setup is Redhat 5.1 i386 on a P133, 40MB RAM.  THis is a firewall to a
cablemodem, so sendmail would be nice ;)

I was having problems where mail was not getting delivered to my box.  I
noticed that a sendmail-8.9.1-2 rpm was available (I had 8.8.something),
so I grabbed it and tried to upgrade.  I'm not sure if it failed or not
but I got bad vibes from it.

[root at kramer bin]# rpm -q sendmail
[root at kramer bin]# rpm --verify sendmail-8.9.1-2
[root at kramer bin]# 

I tried uninstalling then installing again,and it complained about
dependencies, but I overrode them because I was just reinstalling anyway.
There is a remote possibility that I tried installing, not updating.
Could that have done this?

I have NO idea how to proceed from here.  I'm very technical, and pretty
good with sysadmin type stuff, but how do you even research a problem like

Thanks in advance.

DDDD   David Kramer                         dskramer at
DK KD                        
DKK D  The difference between an American and a European is that
DK KD  a European thinks that 100 miles is a long distance while
DDDD   an American thinks that 100 years is a long time

Subcription/unsubscription/info requests: send e-mail with subject of
"subscribe", "unsubscribe", or "info" to discuss-request at

More information about the Discuss mailing list