Segmentation fault (solved ... sort of)

Scott Stirling sstirling at
Mon Feb 7 01:42:31 EST 2000

OK, that makes sense.  So let me ask, was it that the core dump wasn't
created? Or that the core dump couldn't be written to disk becuase of user
permissions?  I would guess the latter was the case.  Otherwise Mandrake
isn't much use for programmers on a multi-user system (unless everyone has
root, which is absurd).

Scott Stirling
West Newton, MA

----- Original Message -----
From: "Brad Noyes" <maitre at>

> Why didn't i get a core dump? Well i haven't been using Mandrake for very
> only about a few weeks. I'm still getting used to it. I tried ulimit, and
> was set to unlimited. So that wasn't the problem. I then tried to run the
> program as super user (by accident, i didn't realize i was in su). And
then i
> got a core dump, which made me happy. After a few tests I concluded that
> Mandrake, only root, or super user can create core dumps.
> I've head of security exploits using a core dump. So i guess thats why
> Mandrake allows only root to create core dumps.
> Now i have to info to fix the problem I just have to figure out how to fix
> problem ...

Subcription/unsubscription/info requests: send e-mail with
"subscribe", "unsubscribe", or "info" on the first line of the
message body to discuss-request at (Subject line is ignored).

More information about the Discuss mailing list