Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

hard disk problem


More follow-up on the hard disk problem we are having:  I received a
couple of suggestions, but so far nothing works yet.

To clarify things a bit: we did get rid of On-track's Disk Manager,
first by using On-track's software to get rid of the stuff on the boot
sector, and (when that didn't fix the problem) also by doing "fdisk
/mbr" under DOS, and repartitioning the whole hard disk from scratch.
As I said, DOS (about 11 MB in partition 1) boots up fine in any case
(whether I but in 708 cylinders or 1416 cylinders in the BIOS) and
things seem to work.  But when booting up under Linux, the system
complains that it can not read the partition table.

I also tried doing the following, suggested by Dan Murphy (murph at

> Set the BIOS to be the true characteristics of the drive. (1416,16,63)
> When you boot Linux, give it a bootparm : ramdisk hda=1416,16,63

This didn't seem to be necessary; upon boot up, the kernel reported
/dev/hda to have 1416 cylinders, etc., and not 708.  But I did it

> Run Linux fdisk : fdisk /dev/hda
> Do a display (p) - things will look messed maybe - this is OK
> Go into expert mode (x)
> Set cylinders = 708
> set track = 32
> Return to normal mode - (r)
> Do another display (p) - things should look normal
> Set up your Linux partitions and write it out.

It tried all these, but this didn't work either.  I still get the "can
not read partition table" message.  If I leave the BIOS setting at
1416 cylinders and 16 heads, that is what the kernel reports upon boot
up.  But on a Gateway pentium machine which has the same type of
Western Digital hard disk (i.e., the AC2700), even though the BIOS is
set at 1416 cylinders, the kernel (same version) reports 708
cylinders instead.  If I set the BIOS to 708 cylinders and 32 heads on
the machine that is giving us problems, then the kernel sees 708/32.

Jim Van Zandt wrote:

> This probably won't help, but...
> My SCSI adaptor has a BIOS setup program which lets me enable
> wide/fast interface, etc.  I can execute the program by typing
> ctrl-A at the right time during boot.  I am not familiar with IDE
> drives, but I wonder if the firmware might offer a way to enable,
> disable, or adjust the remapping.

I'm not familiar with the remapping thing.  Anybody have any

We are getting sort of desperate, and also can't get the kernel to
recognize the NEC x4 CD-ROM driver (attached to a NEC 16-bit AT SCSI
Host Adapter).  We are trying to install Slackware from a CD-ROM, and
none of the SCSI boot disks have been able to recognize /dev/scd0 or
/dev/scd1.  (The kernel always reports 0 SCSI Hosts).  We should
probably do some more reading on the SCSI-HOWTO, but the hard disk
problem is really a puzzle to use.  My colleague has ordered a new
hard disk and see if changing the hard disk will fix the problem.
Otherwise, I'm afraid that we (the Linux user community) will lose
another convert.

Thanks again to all who responded.

Sidney Li
Polaroid Corp.
lih at

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /