Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Palm Pilot as Terminal

This looks as if your Palm software is not sending the proper serial
handshake lines, so getting to work with a direct connection instead of a
modem is likely to be problematic.  You also need some background.

RS-232 serial protocols defines two complementary types of device, Data
Terminal Equipment (DTE) and Data Connection Equipment (DCE).  The
original model use of the protocol is to plug a terminal (DTE) into a
modem (DCE).  As a result, computers are almost always wired as DTE so
that they can plug into modems wired DCE.

Since the purpose of the official Palm serial cable is to do hotsync, and
this implies plugging the Palm into a computer, the Palm emulates a DCE
device in expectation that it will be talking to a DTE computer.  I have
found that, for certain types of connections, you need a "null modem"
adapter; for example, my cellular telephone is also DCE, since it is
mainly intended to be connected to a DTE computer, so plugging the Palm
into the cellular telephone to connect to the Internet requires a null
modem adapter.

Another consideration is that, often, it will be necessary to connect a
9-pin serial connector to a 25-serial connector using an adapter.  Such
adapters often do not wire any of the handshake lines because they are
intended for a mouse rather than a full-function generic device.

Yet another possibility is that the software you have chosen to use does
not correctly manage the handshake lines.  I have no experience with this
particular package, and the PalmOS comes with a built-in dialer that can
be used to establish a PPP connection.  If you set the connection type to
"Unix," you will usually get pretty close to a dialer script that will
work, subject to minor variations (such as changing "user" to "login").  I
have never tried using a direct dial terminal program, since there are
fairly nice telnet and ssh clients available for free:

There is another very nice freeware mail client, too:

MarkSpace has a fairly involved help page for Online, which is their
commercial product that you are trying to use.  My feeling is that, if you
are using a commercial product, then you ought to take advantage of their
support since that is what you are paying for:

-- Mike

On 2000-06-04 at 12:55 -0400, chasen at wrote:

> As the first step of trying to use my new Palm V as a portable terminal, I
> installed a shareware terminal emulation program named Online.  Using the
> Palm cradle directly attached to the serial port on my RH 6.1 Linux box, I
> used cu to write back and forth between the two machines.  This worked
> reasonably well after setting both sides to local echo although cu printed
> ^M instead of moving to a new line.
> Then to actually login to the Linux box I added:
>         S0:2345:respawn:/sbin/mgetty -r -s 38400 ttyS0
> to my /etc/inittab file.  I put Online online and entered a carriage
> return and got the Linux login prompt.  I entered my name and a carriage
> return but never got the password prompt.  The /var/log/mgetty.log.ttyS0
> file shows:
> --
> 06/03 16:50:03 yS0  mgetty: experimental test release 1.1.21-Jul24
> 06/03 16:50:03 yS0  check for lockfiles
> 06/03 16:50:03 yS0  locking the line
> 06/03 16:50:04 yS0  WARNING: DSR is off - modem turned off or bad cable?
> 06/03 16:50:04 yS0  waiting...
> 06/03 16:53:24 yS0  WARNING: starting login while DCD is low!
> 06/03 16:53:24 ##### data dev=ttyS0, pid=20310, caller='none',
> conn='DIRECT', name='', cmd='/bin/login', user='frank'
> --
> 06/03 16:54:24 yS0  mgetty: experimental test release 1.1.21-Jul24
> 06/03 16:54:24 yS0  check for lockfiles
> 06/03 16:54:24 yS0  locking the line
> 06/03 16:54:25 yS0  waiting...
> Login apparently timed out after 60 seconds and mgetty restarted.
> Any ideas on why login is not sending the password prompt?

Subcription/unsubscription/info requests: send e-mail with
"subscribe", "unsubscribe", or "info" on the first line of the
message body to discuss-request at (Subject line is ignored).

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /