Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


> hello to all,
>       i'm really having trouble configuring an
> ethernet card (3com 509 etherworks) in a RH6.0 kernel
> 2.2.5-15.  Ive tried disabling PnP and changing IRQ
> through a utility that comes with the card by booting
> with win98 bootdisk. When I run ifconfig eth0
>, everything seems to be fine, it even
> gives a ping reply, but when I run route eth0 -net
> it gives the message: unable to locate
> device eth0. And when I reboot, it can't bring up eth0
> giving the message:unable to resolve IP.... operation
> failed..

Why are you running the 'route' command?  It's not normally necessary.

Could you please send copies of 

- the /etc/conf.modules file
- the output of 'ifconfig eth0' 
- the exact 'route' command and output.  

I suspect you're trying too hard.   The routing should be set up when you
turn the interface on.  Note this excerpt from the man page for route:

       dev If Forces  the  route to be associated with the speci-
              fied device, as the kernel will  otherwise  try  to
              determine  the  device  on  its  own  (by  checking
              already existing routes and device  specifications,
              and  where  the  route is added to). In most normal
              networks you won't need this.

And, the syntax for the command is more like:

	route add -net netmask dev eth0

Subcription/unsubscription/info requests: send e-mail with
"subscribe", "unsubscribe", or "info" on the first line of the
message body to discuss-request at (Subject line is ignored).

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /