Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

WEP and Atmel driver

Ok, since my USB wireless seemed responsible for significant crashes (due 
to what I'm told is a race condition in 2.4.25/26 kernel) I picked up
a cheapie Belkin wireless pcmcia card to give that a shot.

I've got the atmel wlan driver from sourceforge, it's compiled and 
installed and everything seems ducky.  I have an atml0 device, and the 
command line tools can execute scans for my access point just fine (and 
find it, and appear to do everything accept give me an IP).

The problem is WEP.  Whenever I do a /sbin/iwconfig the device always tells 
me that encryption is off.  If I run one of the config programs the driver 
came with (lvnet or winter) I can specify WEP, but I still have no IP for 
the device.  And once I try an /sbin/ifup on it I'm back to having no 

Does anybody know which knob I should be frobbing in order to get it to 
recognize WEP?  I think that's the last step.  It's recognized when I 
insert the card, the module driver loads properly, and I see a bunch of 
"DHCP DISCOVER" lines in the system log.  But I am assuming that since I 
have no wep, that my access point is not answering.

This all worked fine in the wlan0 world, by the way.  So if somebody can 
tell me how to make atml0 call itself wlan0 that might be an easy solution.
When I switched from my netgear card (which broke) to usb, all I did was 
change /etc/modules.conf from "alias wlan0 prism2_cs" to "alias wlan0 
prism2_usb" and everything worked just fine.  But this new driver's 
insistence on calling itself something other than wlan0 screws up all of 
the config files that I might have hardwired to that constant.



BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /