Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

WEP and Atmel driver

How do I know if I'm using wlan-ng-config?  I'm uaing the linux-wlan 
project stuff.  I have manually changed wlan.conf (and wireles.opts and 
every other file I can get my hands on) to do what appears to be the right 

iwconfig appears to tell me the right thing.  It tells me that lo and eth0 
have no wireless extensions, but then gives me the whole rundown on atml0.  
I run the 'lvnet' program it comes with, set wep and associated myself 
with my access point, and then rerun iwconfig and it has all that 

I'm just missing an IP.  What command do I need to run to tell me device 
to go out and look for a DHCP connection?  If I run ifup (which, because 
of the wireless extensions, runs ifup-wireless) I immediately get a 
message saying "No Encryption AnyMore" (which is in the atmel source 
code), I never connect, and sure enough rerunning iwconfig tells me that 
WEP is disabled again.


 On Wed, 23 Jun 2004, konrad wrote:

> If you are using wlan-ng-config, the 'iwconfig' utility is not supported.
> You have to modify the wlan.conf to set the right WEP and SSID.
> ---
> konrad
> On Tue, 22 Jun 2004, Duane Morin wrote:
> > Ok, since my USB wireless seemed responsible for significant crashes (due
> > to what I'm told is a race condition in 2.4.25/26 kernel) I picked up
> > a cheapie Belkin wireless pcmcia card to give that a shot.
> >
> > I've got the atmel wlan driver from sourceforge, it's compiled and
> > installed and everything seems ducky.  I have an atml0 device, and the
> > command line tools can execute scans for my access point just fine (and
> > find it, and appear to do everything accept give me an IP).
> >
> > The problem is WEP.  Whenever I do a /sbin/iwconfig the device always tells
> > me that encryption is off.  If I run one of the config programs the driver
> > came with (lvnet or winter) I can specify WEP, but I still have no IP for
> > the device.  And once I try an /sbin/ifup on it I'm back to having no
> > encryption.
> >
> > Does anybody know which knob I should be frobbing in order to get it to
> > recognize WEP?  I think that's the last step.  It's recognized when I
> > insert the card, the module driver loads properly, and I see a bunch of
> > "DHCP DISCOVER" lines in the system log.  But I am assuming that since I
> > have no wep, that my access point is not answering.
> >
> > This all worked fine in the wlan0 world, by the way.  So if somebody can
> > tell me how to make atml0 call itself wlan0 that might be an easy solution.
> > When I switched from my netgear card (which broke) to usb, all I did was
> > change /etc/modules.conf from "alias wlan0 prism2_cs" to "alias wlan0
> > prism2_usb" and everything worked just fine.  But this new driver's
> > insistence on calling itself something other than wlan0 screws up all of
> > the config files that I might have hardwired to that constant.
> >
> > Thanks!
> >
> > Duane
> >
> > _______________________________________________
> > Discuss mailing list
> > Discuss at
> >
> >

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /