Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ALSA woes / alsaconf

   I've run into trouble upgrading my box (kernel 2.6.9) -- ALSA is no 
longer functional.  All of the relevant modules load fine, but I get 
nothing in terms of sound output.  I've manually unmuted channels, etc., 
but zip ... UNLESS I run alsaconf, the utility included with ALSA. 
After running alsaconf, everything works great until the next reboot.
   Comparing the modules loaded before and after running alsaconf, it 
looks like alsaconf loads two additional mods (snd_pcm_oss and 
snd_mixer_oss).  I've tried loading those by hand, but still no sound 
after loading.  This leads me to believe that alsaconf is 
muting/unmuting something useful -- does anyone know what alsaconf does 
after loading the relevant mods?  It says something about unmuting 
channels (I tried alsaconf -L to log output, but the logging output is 
   The only other hint I can offer is that ALSA isn't properly storing 
its levels when shutting down, even though SAVE_ON_STOP is set to "yes".


Up-to-date Gentoo installation
Intel i8x0 sound card (IBM Thinkpad T41)
Kernel 2.6.9
using kernel mod sound drivers instead of alsa-distributed drivers, as 
recommended by Gentoo docs

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /