Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

ALSA woes / alsaconf

On Aug 19 2005, Dan Barrett wrote:

You should have all the proper modules setup somewhere in /etc/modules.d/, 
including the ones that don't seem to be loading properly at boot. After 
making changes in there, you need to do a modules-update. It's strange that 
alsaconf isn't setting that part up for you properly, but this is where the 
changes belong.

As for the mute levels, you should have used rc-update to add a service for 
alsa to restore the mixer levels each time you reboot. When you reboot you 
should get a friendly message saying Restoring Mixer Levels [ OK ] or 
something to that effect.

To test that the level restoration actually works, do a 
/etc/init.d/alsa restart
this will be a lot more efficient than repeated reboots.

ALSO, when using alsamixer, just because you have the levels set way up 
doesn't mean that you've unmuted a channel. Try using the m key to toggle 
the mute on a channel, and use your left / right keys to make sure you're 
checking EVERY channel. If you have a nice Creative EMU10K card like me, 
you have something ridiculous, like more than 20 channels. If you have four 
or five audio outputs, plug into each one to make sure you're not doing 
something silly, like plugging into your Sub channel instead of Front or 
something like that.

> Folks,
>    I've run into trouble upgrading my box (kernel 2.6.9) -- ALSA is no 
> longer functional.  All of the relevant modules load fine, but I get 
> nothing in terms of sound output.  I've manually unmuted channels, etc., 
> but zip ... UNLESS I run alsaconf, the utility included with ALSA. 
> After running alsaconf, everything works great until the next reboot.
>    Comparing the modules loaded before and after running alsaconf, it 
> looks like alsaconf loads two additional mods (snd_pcm_oss and 
> snd_mixer_oss).  I've tried loading those by hand, but still no sound 
> after loading.  This leads me to believe that alsaconf is 
> muting/unmuting something useful -- does anyone know what alsaconf does 
> after loading the relevant mods?  It says something about unmuting 
> channels (I tried alsaconf -L to log output, but the logging output is 
> useless).
>    The only other hint I can offer is that ALSA isn't properly storing 
> its levels when shutting down, even though SAVE_ON_STOP is set to "yes".
> Help!
> d.
> Up-to-date Gentoo installation
> Intel i8x0 sound card (IBM Thinkpad T41)
> Kernel 2.6.9
> using kernel mod sound drivers instead of alsa-distributed drivers, as 
> recommended by Gentoo docs
> _______________________________________________
> Discuss mailing list
> Discuss at

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /