Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss] How to mount an Android device in Linux -- solution

Brendan Kidwell wrote:
> I got a Nexus 7 a couple of months ago and I was frustrated by the lack of
> good support for accessing Android 4.0+'s filesystem via USB from a Linux
> client.

What's the underlying issue?

Is it really a new file system or is it addressing flaws in the USB
driver on the Linux side?

> Andrew at Web Upd8 took the "go-mtpfs" driver and made a nice Ubuntu
> package for it...
> I tried this on Linux Mint and it worked just fine.

Thanks for sharing the tip.

I haven't yet had much need to transfer large file to my Nexus 7, but I
did recently set up an rsync client[1] to back it up. Backing up worked
fine, though I'm still working out issues with the scheduler (using
Llama[2], which doesn't seem to be working as expected).


The problem I ran into was when I wanted to sync a small subset of files
in the other direction - from my desktop to the Nexus 7. Then I ran into
rsync complaining that it didn't have permission to set the times on
files. This is because although the non-privileged users that the apps
run as have write access to the file system, all files are created with
root ownership, and you can only set the timestamp on an inode if you
own it. I haven't seen a solution, other than telling rsync not to
attempt to set timestamps, or presumably rooting.


Tom Metro
Venture Logic, Newton, MA, USA
"Enterprise solutions through open source."
Professional Profile:

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /