Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Anyone using digital camera with RH 8.0?

It seems like it almost works.  If I plug it into a USB  port,  lsusb
tells  me  about  the  camera  and  correctly identifies the make and
model. That should be proof that the hardware, driver, hotplug stuff,
etc., is all working.

Now to figure out how to get the pictures off the camera and onto the
disk.   I  tried  the  gtkam  tool,  but  it  has the problem that is
described in the FAQs:  It says that it can't initialize the  camera.
After  a  bit  of futzing, I got it to give me the "*** Error ('Could
not claim the USB device') ***" explanation that is mentioned  in  at
least one FAQ.  But this is a brick wall.

The problem is there are lots of explanations in the FAQ and in other
docs  that  I  need to get the permissions right on "the USB device",
but nowhere does anyone say what the device is  called.   The  string
"/dev/" doesn't seem to appear in any docs or error messages, or even
in /var/log/messages.  If I knew the device name, I could easily type
a "chmod ugo+rw ..." for it, but I don't know the pathname.

There is a /dev/usb/ directory with lots of special files, but when I
change  their  permissions  to 0666, it has no effect on anything.  I
still get told that I  don't  have  permission  to  access  "the  USB
device".  So it's gotta be something else.

One curiosity is that I've seen a number of claims that one can  just
mount  the  camera  as  a filesystem and cp the files.  A week or two
back, when I was experimenting with this and  getting  all  sorts  of
errors,  I  suddenly  discovered that in fact the camera was mounted,
and I did a quick copy of some pictures with a  cp  command.   But  I
never  figured  out  what  I did that got it got mounted, and after I
unmounted it, I've never again  succeeded  in  stumbling  across  the
incantation that does the job.

I've also never found any documentation that shows  a  mount  command
for  a  camera.   I've  found  them  for other USB devices, but those
examples don't suffice to construct a mount command for  the  camera.
And there's a problem with the /dev/usb/* special files: They are all
character devices, so mount instantly rejects them.

I have evidence that,  contrary  to  all  intuition,  the  camera  is
actually called "/dev/sda".  When I try "mount /dev/sda /mnt/camera",
I see the camera's lights flickering for several seconds, and then it
tells  me that I need to specify the type.  OK, I think, and add in a
-t option with a guess as to the type.  The camera's  lights  flicker
again, and it tells me that's the wrong type. I go through the entire
set of mount types listed in "man mount", and all of  them  fail  the
same  way.   So  whatever the filesystem type is, it's not one of the
types listed by the "man mount" command.  It's also not  any  of  the
types in the /etc/filesystems file.

The ideal solution would probably be an /etc/fstab  entry  that  does
the  mount.   I don't seem to find any examples of this, either.  And
unless I can find the proper type, this won't work, either.

My conclusions:  This is doable, since I saw it  (accidentally)  work
once.   But  there's  no  way I would recommend this system to anyone
trying to do fun stuff with a digital camera, until I can find a  way
past the frustration of trying to get the system to mount the camera.

Any suggestions?

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /