Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Waiting for Transaction Lock when installing rpm

Due to a server crash last night, I'm temporarily setting up my
workstation as a mail server, running Fedora Core 2.  To that end, I'm
trying to
install some rpms for clamav.

I tried the normal rpm install:
	rpm -Uvh <rpm name>
and it seemed to hang.  I terminated the shell in which this was running,
and tried again, and got the following:
	warning: waiting for transaction lock
	error: can't create transaction lock

The process that was running the original rpm is still around, even
when trying to kill-9 it:
	root     31879     1  0 09:15 ?        00:00:00 rpm -Uvh

Any thoughts on:
1) How to kill the previous process when kill -9 doesn't?
2) Any other way to get this rpm to install?


BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /