Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


Kent Borg writes:
| Do you have telnet on?
| Make it come on at every boot with (as root):
|   # chkconfig telnet on

This one I hadn't seen, so I tried it.  What I got was:

: chkconfig telnet on
error reading information on service telnet: No such file or directory

Doesn't seem to have worked on this 2.2.13-0.7 (Red Hat) box.  I also
note it commits one of the traditional sins of bad software: It tells
me that it can't open something, but it doesn't deign to tell me what
the  file name was.  Now, it certainly knew, since it just passed the
name to the kernel.  It could easily have included the  name  in  the
error message, and I'd have a clue where to start looking. But no; it
says in effect "There's something missing, and I'm not gonna give you
any clue as to what it is.  Nyah, nyah, nyah."

The problem isn't with the /etc/services file, which exists, has  644
permissions, and has the usual "telnet 23/tcp" entry.  I wonder where
else to look.  "man chconfig" doesn't seem to contain any clues.

Sure wish we could find the turkeys who write code like  this,  rough
them up a bit, and see if they get the message.

Subcription/unsubscription/info requests: send e-mail with
"subscribe", "unsubscribe", or "info" on the first line of the
message body to discuss-request at (Subject line is ignored).

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /