Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Getting chars 128-255 to display properly

Recently I picked up a number of files from  a  Scandinavian  friend,
untarred  them,  and  of  course some of the file names have "marked"
letters in the upper half of the  char  set.   This  seems  to  cause
problems  that  are  surprising  in a modern system like linux, and I
suspect that the problems can be solved, but digging  around  in  TFM
and assorted FAQs didn't turn up many answers.

One curiosity:  I have good evidence that part of the problem is with
the bash and (t)csh shells.  The evidence is that if I run ksh in  an
xterm,  there  don't seem to be problems.  I can enter the high-order
chars using the ALT key (plus a chart of the keyboard mapping that  I
keep handy).  Cut-and-paste to and from the xterm and other apps then
works fine. But when I run bash or csh in the same window, chars like
ALT-d  (which  is umlaut-a) and ALT-X (slash-O) don't work.  The file
names come out on the screen fine, but I can't copy them into a  bash
or csh command line.

Also, if I run vi in the xterm, the problems go away.

Is  it just that bash and (t)csh are still stuck in 7-bit mode?  This
seems unlikely, especially considering linux's origins.  But if  not,
then  presumably  there's  some  setting  that  I  can't find that is
telling them to reject  high-order  chars.   It  isn't  in  the  stty
settings; I've verified that they are the same for bash, csh and ksh.
The bash and csh man pages don't seem to mention character-set topics
at all.

There also seems to be a problem with telnet.   When  I  log  into  a
remote  machine,  characters  like  )B? and ? show up as \xe4 and \xf8,
even though they act like the single characters that they are. Again,
there  seems to be no apparent explanation for this expansion, and no
obvious way to say "Just pass the 8-bit chars on; I can handle them."
According  to  stty,  8-bit  chars  are turned on everywhere, so this
shouldn't be happening, but it it.

Is there a coherent explanation to what's going wrong here and how to
fix  it?   This  sort of thing must frustrate our European friends no
end.  And lots of us English-speaking types need to deal  with  other
languages sanely ...

(I hope I'm not stuck using ksh as a shell.  Shudder ... ;-)

Subcription/unsubscription/info requests: send e-mail with
"subscribe", "unsubscribe", or "info" on the first line of the
message body to discuss-request at (Subject line is ignored).

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /