Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Tape-caused hang (was IPChains question (SOLVED))

Jerry Callen wrote:
> Ron Peterson wrote:
> > [...]
> > So I sat down at the server
> > console, and I couldn't even log in.  Couldn't use ssh to get in
> > either.  I was contemplating hitting the power switch (ouch), but tried
> > turning off the tape drive first.  Presto.  Everything came back.
> >
> > Yikes.
> Yikes is right! This sounds like lameness in a device driver.

Come to think of it, this couldn't have anything to do w/ firewall
timeout values - I was behind the firewall (I thought the discussion had
also mentioned ssh timeouts, but no).

I don't understand what happened at all, then.  Like I said, the console
was completely dead.  When I tried to ssh, I got an error message that
said "... (no core)".

Tape is a Sony PCBacker DDS-4.  Red Hat 6.1 (2.2.13).

I suppose I could experiment, and try running my backup script via ssh a
few more times to see what happens.  But probably not while people are
trying to work...

I've never had the server or the tape drive even hiccup before.



p.s. - for the curious, here is the extrememly complicated and confusing
backup script I ran.  home3 is a 50GB RAID5 drive.

cd /home3

# don't redirect error to log file.  will be mailed to root by crond
tar --atime-preserve \
    --create \
    --verbose \
    --verbose \
    --label="created `date +%Y-%m-%d`" \
    --file=/dev/st0 wfdg 1>/var/log/backup/backup.log
Subcription/unsubscription/info requests: send e-mail with
"subscribe", "unsubscribe", or "info" on the first line of the
message body to discuss-request at (Subject line is ignored).

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /