Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub on MBR just won't "take"

This is an odd problem, one I've neither seen befroe nor been able to
find anything about.  Due to a recent system crash, I'm rebuilding a
machine using Fedora 2 (though the distro shouldn't affect this
particular problem).  The installation seemed to go OK, but when booting
the machine for the first time the boot record in the MBR was not

>From what I can tell, everything is where it thinks it is; my /boot
partition is in fact on hda1 (hd0,0).  The stage1 and stage2 files seem
to be in the proper places.  But the system just won't boot.  I've tried
grub-install, and that reports a successful return code, but still no

I booted using a rescue CD, mounted the extant file system, and made a
boot floppy without a problem.  I can boot using that floppy, and the
machine boots properly, though interestingly it asks me if I want to
boot to hda2 (my / partition), not hda1 (/boot), though I guess that
could make sense.  The machine seems to be running properly when booted
from the floppy.

While I could live like that, I'd much rather not be floppy-dependent. 
Any thoughts on what the problem might be?  Could this be a hardware
problem, that just doesn't report any errors?


BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /