Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Grub on MBR just won't "take"

On Tue, 27 Jul 2004 20:09:32 -0400, Don Levey <lug at> wrote:
> I've tried grub-install, and that reports a successful return code, but still no
> go.

I didn't use grub-install, but I'm using grub. What I did is this:

# grub
grub> root (hd0,0) [assuming you're using /dev/hda1 as your /boot]
grub> setup (hd0) [assuming the MBR in question is on /dev/hda]
grub> quit

Then I edited /boot/grub/grub.conf:

timeout 3
default 0

title=Gentoo Linux 2.6.7-r11
kernel /kernel-2.6.7-gentoo-r11 root=/dev/ram0 real_root=/dev/hda3
init=/linuxrc video=vesafb:ywrap,mtrr vga=0x31B
initrd /initrd-2.6.7-gentoo-r11

Hope that helps.


Gordon Marx
gcmarx at

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /