Boston Linux & Unix (BLU) Home | Calendar | Mail Lists | List Archives | Desktop SIG | Hardware Hacking SIG
Wiki | Flickr | PicasaWeb | Video | Maps & Directions | Installfests | Keysignings
Linux Cafe | Meeting Notes | Blog | Linux Links | Bling | About BLU

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Knoppix on my laptop

Jarod Wilson wrote:
> On Jul 14, 2007, at 16:51, Jerry Feldman wrote:
>> On Sat, 14 Jul 2007 12:05:27 -0400 (EDT)
>> Scott Ehrlich <scott-DPNOqEs/LNQ at> wrote:
>>> My AMD64 Compaq Presario with ATA/IDE CD/DVD factory drive, currently
>>> running Ubuntu 7.04, refuses to let Knoppix run on it.   Both the 
>>> Knoppix
>>> 5.0.1 DVD and 5.1.1 CD freeze the system at checking /dev/hda for 
>>> Knoppix
>>> CD.
>>> I've seen this kind of thing happen before on other systems, but
>>> eventually the check would find the disk and continue with booting.  I
>>> think I've let it sit there for 30 minutes at one point with no change.
>>> The Compaq is obviously new enough (purchased new a couple years ago) 
>>> that
>>> Knoppix should have *no* problems.
>>> Ideas/insights welcome.   CentOS and Ubuntu Live both boot fine.
>> I'm researching also. Can you try Knoppix 4.x?
>> A few options I have not yet tried: nosmp, expert, noapm (although I've
>> tried failsafe that should turn apm off).
> It could be that the latest knoppix is using the new libata stack, 
> instead of the old pata drivers, and the new libata driver for your pata 
> chipset isn't being automagically loaded. Exactly how to fix that, if it 
> is the case, I don't know offhand...
> --Jarod Wilson
If that is the case then there is some minimal help in 
'kernelparameters.txt' under documentation in the recent 
kernel source. The libata driver is a new animal and defines 
all hd0 as scsi or sd01 etc...

Jim K-R

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /