Boston Linux & UNIX was originally founded in 1994 as part of The Boston Computer Society. We meet on the third Wednesday of each month at the Massachusetts Institute of Technology, in Building E51.

BLU Discuss list archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Discuss] I, uh, deleted the wrong kernel....

David kramer <david at> writes:

> On my desktop machine (Kubuntu 16.04LTS I think), I set up /boot too
> small, because at one point my distro automatically removed old kernels,
> so there wasn't need for much space.  But that doesn't happen anymore,
> so sometimes it fills up.  Well it turned out that when I went to delete
> some of the older kernels, it turns out I was actually running one of
> them, and now Grub is very unhappy.  This is dual boot with Windows,
> which still works. 
> I'm sending this from my laptop.  It's now like 2AM so I need to get to
> bed.  I have tried a bunch of things, but clearly I didn't exhaust
> Google yet.  I'm posting this in case someone who has experience in this
> can just head me towards The One True Way to fix this.  I will continue
> trying tomorrow though.
> Grub is looking for vmlinux-4.4.0-28-generic, and I have
> vmlinux-4.4.0-34-generic and vmlinux-4.4.0-36-generic still.

Have you tried simply entering the boot commands for each of these
remaining kernels at the grub prompt on boot? That's really the one
benefit of Grub that justifies its complexity compared to other boot
loaders, that boot time has a general boot command interpreter and the
ability to read linux file systems (cf. Lilo's lesser capabilities where
it can only deal in block offsets). It's saved my bacon in the
past. Once you get booted properly into your environment it should be
easier to correct the config file.

Mike Small
smallm at

BLU is a member of BostonUserGroups
BLU is a member of BostonUserGroups
We also thank MIT for the use of their facilities.

Valid HTML 4.01! Valid CSS!

Boston Linux & Unix /